


  



<!DOCTYPE html>
        <html lang="en">
        <head>

<meta name="keywords" content="twin falls times-news" />
<meta name="description" content="" />
<meta name="author" content="Twin Falls Times-News" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=375099832" />
<meta name="google-play-app" content="app-id=com.magicvalley.news" />
<meta name="google-site-verification" content="m1RFSu3HgkLm7UOImoVL_lGb_BBeAaZwOYKq8jsVoTc" />
<meta property="og:type" content="website" />
<meta property="og:url" content="https://magicvalley.com/template/second-street/" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/598cea12-c548-11ea-8c5d-3f5d3349e5f2.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Second-street" />
<meta property="og:site_name" content="Twin Falls Times-News" />
<meta property="og:section" content="template" />
<meta property="article:publisher" content="https://www.facebook.com/thetimesnews/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@twinfallstn" />
<meta property="fb:pages" content="293729833266" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.83ca941054ac727e5ed44a182cce1ac1.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/live/libraries/flex/components/lee_ds_v2/resources/styles/lee.ds.css?_dc=1624604508"/>
<style>/*<![CDATA[*/ #block-1809898 .search-spinner { position: absolute; } #block-1809898 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #user-controls-1809899 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1809899 .tn-user-screenname, #user-controls-1809899 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1809899 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1809899 .dropdown-signup { font-size: 12px; } #user-controls-1809899 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1809899 .large-user-avatar { margin-right: 10px; } #user-controls-1809899 .large-user-controls { font-size: 12px; } #user-controls-1809899 .logout-btn { cursor: pointer; } #user-controls-1809899 .login-btn { background-color: #0272af; border-color: #0272af; } #user-controls-1809899 .login-btn:hover { text-decoration: underline; } .follow-links-1809892 li { margin-right: 1px; padding: 0; } .follow-links-1809892 li a, .follow-links-1809892 li a:focus, .follow-links-1809892 li a:active { ; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1809892 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1809892 li a.fb,.follow-links-1809892 li a.fb:hover { color: #3A59A5; } .follow-links-1809892 li a.tw,.follow-links-1809892 li a.tw:hover { color: #46C8F9; } .follow-links-1809892 li a.yt,.follow-links-1809892 li a.yt:hover { color: #CE2B29; } #tncms-block-1809858 .tnt-prop-img { max-width: 300px; } #site-logo-1809858 { color: #666; } #tncms-block-1809857 .tnt-prop-img { max-width: 700px; } #site-logo-1809857 { color: #666; } #site-logo-1809857 .list-inline, #site-logo-1809857 .logo-date { display: inline-block; margin-bottom: 0; font-size: 12px; } #site-logo-1809857 .logo-top ul, #site-logo-1809857 .logo-top div { margin-bottom: 10px; } #site-logo-1809857 .logo-bottom ul, #site-logo-1809857 .logo-bottom div { margin-top: 10px; } #weather-1814365 .list-unstyled { margin: 0; } #weather-1814365 span { display: block; } #weather-1814365 .forecast-link a { padding: 8px; margin-top: -10px; } #weather-1814365 .icon { position: relative; } #weather-1814365 .icon .tnt-svg { position: relative; font-size: 58px; margin-bottom: -6px; margin-right: 10px; margin-top: -8px; } #weather-1814365 .temp { font-size: 32px; line-height: 32px; margin-top: 4px; font-weight: bold; } #weather-1814365 .cond { opacity: 0.7; } #weather-1814365 .current-conditions { float: left; height: 50px; } #weather-1814365 .dropdown-toggle { color: #212121; display: block; } #weather-1814365 .weather-alert-btn { right: 0; position: absolute; margin-right: 5px; margin-top: 0px; z-index: 1; } #weather-1814365 .weather-alert-btn .tnt-svg { font-size: 12px; margin: 0; } #tncms-block-1809893 .tnt-prop-img { max-width: 700px; } #site-logo-1809893 { color: #666; } .follow-links-1809894 li { margin-right: 1px; padding: 0; } .follow-links-1809894 li a, .follow-links-1809894 li a:focus, .follow-links-1809894 li a:active { ; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1809894 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1809894 li a.fb,.follow-links-1809894 li a.fb:hover { color: #3A59A5; } .follow-links-1809894 li a.tw,.follow-links-1809894 li a.tw:hover { color: #46C8F9; } .follow-links-1809894 li a.yt,.follow-links-1809894 li a.yt:hover { color: #CE2B29; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.58.1"}},"tncms":{"asset":{},"page":{"app":"editorial","skin":"flex-editorial","theme":"flex","http_status":200},"client":{"is_bot":"yes","noscript":false,"is_gdpr":"no"},"system":{"render_time":181}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/6894/cc.js?ns=_cc6894" id="LOTCC_6894"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc6894.add('tp', 'TNNW');
		_cc6894.add('act', ' User Login');
		_cc6894.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc6894.bcp();
</script>

<script>/*<![CDATA[*/ window.LEE_DS = true; /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="http://magicvalley.com/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1a9cd24ef9d9815fbbfe1cf9d9c6520f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script>/*<![CDATA[*/ __tnt.adBlockEnabled = function() {
        if( __tnt.user.services ){ 
            return false; 
        }
        return true;
    } /*]]>*/</script>
<script>/*<![CDATA[*/ (function(){
        if( __tnt.adBlockEnabled() ){
            var gcfs = document.createElement('script');
                gcfs.src = 'https://contributor.google.com/scripts/b765fd5c002b8ec/loader.js';
            var gcft = document.getElementsByTagName('script')[0];
                gcft.parentNode.insertBefore(gcfs, gcft);
        }
    })(); /*]]>*/</script>
<script>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</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="http://magicvalley.com/shared-content/art/tncms/tracking.js"></script>
<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="d39f1bf3-a52d-4217-aa84-7c84d2b14e1d"></script>

            
            <title>Second-street | magicvalley.com</title><link rel="dns-prefetch" href="https://bloximages.chicago2.vip.townnews.com"/><link rel="dns-prefetch" href="//33across-d.openx.net"/><link rel="dns-prefetch" href="//a.wishabi.com"/><link rel="dns-prefetch" href="//aax.amazon-adsystem.com"/><link rel="dns-prefetch" href="//ads.pubmatic.com"/><link rel="dns-prefetch" href="//amazon-tam-match.dotomi.com"/><link rel="dns-prefetch" href="//ap.lijit.com"/><link rel="dns-prefetch" href="//api.circularhub.com"/><link rel="dns-prefetch" href="//b.scorecardresearch.com"/><link rel="dns-prefetch" href="//b.wishabi.com"/><link rel="dns-prefetch" href="//bh.contextweb.com"/><link rel="dns-prefetch" href="//c.amazon-adsystem.com"/><link rel="dns-prefetch" href="//casper.iloveadeal.com"/><link rel="dns-prefetch" href="//cdn-sic.33across.com"/><link rel="dns-prefetch" href="//cdn.ampproject.org"/><link rel="dns-prefetch" href="//cdn.blueconic.net"/><link rel="dns-prefetch" href="//cdn.districtm.io"/><link rel="dns-prefetch" href="//cdn.tynt.com"/><link rel="dns-prefetch" href="//cdnjs.cloudflare.com"/><link rel="dns-prefetch" href="//cm.g.doubleclick.net"/><link rel="dns-prefetch" href="//cms-xch.33across.com"/><link rel="dns-prefetch" href="//connect.facebook.net"/><link rel="dns-prefetch" href="//contributor.google.com"/><link rel="dns-prefetch" href="//cookie.brealtime.com"/><link rel="dns-prefetch" href="//d1z2jf7jlzjs58.cloudfront.net"/><link rel="dns-prefetch" href="//dealperform-images.s3.amazonaws.com"/><link rel="dns-prefetch" href="//dsum.casalemedia.com"/><link rel="dns-prefetch" href="//eb2.3lift.com"/><link rel="dns-prefetch" href="//f.wishabi.net"/><link rel="dns-prefetch" href="//fonts.googleapis.com"/><link rel="dns-prefetch" href="//fonts.gstatic.com"/><link rel="dns-prefetch" href="//fundingchoicesmessages.google.com"/><link rel="dns-prefetch" href="//ib.adnxs.com"/><link rel="dns-prefetch" href="//idsync.rlcdn.com"/><link rel="dns-prefetch" href="//image2.pubmatic.com"/><link rel="dns-prefetch" href="//images.wishabi.net"/><link rel="dns-prefetch" href="//lee.blueconic.net"/><link rel="dns-prefetch" href="//match.adsrvr.org"/><link rel="dns-prefetch" href="//pixel.advertising.com"/><link rel="dns-prefetch" href="//pixel.rubiconproject.com"/><link rel="dns-prefetch" href="//pubads.g.doubleclick.net"/><link rel="dns-prefetch" href="//rtb-csync.smartadserver.com"/><link rel="dns-prefetch" href="//s.amazon-adsystem.com"/><link rel="dns-prefetch" href="//sb.scorecardresearch.com"/><link rel="dns-prefetch" href="//secure-assets.rubiconproject.com"/><link rel="dns-prefetch" href="//secure.adnxs.com"/><link rel="dns-prefetch" href="//sic.33across.com"/><link rel="dns-prefetch" href="//ssc-cms.33across.com"/><link rel="dns-prefetch" href="//ssc.33across.com"/><link rel="dns-prefetch" href="//staticxx.facebook.com"/><link rel="dns-prefetch" href="//survey.g.doubleclick.net"/><link rel="dns-prefetch" href="//sync.search.spotxchange.com"/><link rel="dns-prefetch" href="//t.myvisualiq.net"/><link rel="dns-prefetch" href="//tags.bluekai.com"/><link rel="dns-prefetch" href="//tapestry.tapad.com"/><link rel="dns-prefetch" href="//us-u.openx.net"/><link rel="dns-prefetch" href="//www.facebook.com"/><link rel="dns-prefetch" href="//www.googletagservices.com"/>
            
    <style>body { background-color: #ffffff; color: #222222; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #99231b; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #main-navigation { background-color: #f7f7f7; } .fixed-nav #main-navigation { background-color: #f7f7f7 !important; } #site-top-nav { background-color: #ffffff; } #site-footer { background-color: #f7f7f7; color: #888888; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #666; } .navbar-toggle .icon-bar { background-color: #666 !important; } .navbar-toggle .sr-only-show { color: #666 !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #222222; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #666; } }#site-copyright a, #site-footer a { color: #333333; }.btn-primary, .nav-pills>li.active>a,.card.author .btn-success,.profile-about .btn-success { color: #fff!important; background-color: #99231b!important; border-color:#99231b!important; }.btn-primary:hover { opacity: .8; }.btn:focus { outline:1; outline-color: #222; }a:focus { color: #99231b; outline:1; outline-color: #222; }section:focus,aside:focus { outline:0; }.offcanvas-drawer, #fixed-article-header{ visibility: hidden; }.drawer-open .offcanvas-drawer, #fixed-article-header.sticky { visibility: visible; }.search-form-dropdown.open .btn, #site-footer a, .branding-links a { color: #99231b!important; } .container-breakout.photos-container { border-top: 10px solid #c1392f; }</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://magicvalley.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Second-street | magicvalley.com" href="http://magicvalley.com/search/?f=rss&amp;t=article&amp;c=template/second-street&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://magicvalley.com/template/second-street/" />
            <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" charset="UTF-8" ccpa-opt-out-ids="C0004" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="false" async></script><script defer src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
        
<meta property="og:title" content="Here's the Scoop Sweepstakes"/>
<meta property="og:description" content="Win $500 in our Here's the Scoop Sweepstakes"/>
<meta property="og:image" content="https://media.secondstreetapp.com/4301559?width=1200&height=630"/></head>
        <body class="fixed-scroll-nav app-editorial grid-simple  section-template section-second-street" data-path="/template/second-street">
	<script type='text/javascript' src='http://magicvalley.com/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('magicvalley.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.58.1&amp;tncms.page.app=editorial&amp;tncms.page.skin=flex-editorial&amp;tncms.page.theme=flex&amp;tncms.page.http_status=200&amp;tncms.client.is_bot=yes&amp;tncms.client.noscript=yes&amp;tncms.client.is_gdpr=no&amp;tncms.system.render_time=181" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><a href="https://magicvalley.com/template/second-street/#main-page-container" class="sr-only sr-only-focusable">Skip to main content</a><script>
            (function() { 
                if(!__tnt.user.loggedIn){
                    var ARTICLE_URL = window.location.href; 
                    var CONTENT_ID = 'everything';
                    document.write(
                        '<scr'+'ipt '+ 
                        'src="//survey.g.doubleclick.net/survey?site=_6ryiuaui2rxjxxjt4e7cwn3hvu'+ 
                        '&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
                        (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
                        '&amp;random='+(new Date).getTime()+ 
                        '">'+'\x3C/scr'+'ipt>'
                    );
                    __tnt.log('Google Survey: script loaded');
                }
            })();
        </script>
        
        
        <!-- Google Tag Manager -->
    <script>
        var dataLayer = window.dataLayer || [];
        dataLayer.push({"ga_ua":"UA-54716522-2","chartbeat":"true","gravity":"8e869b3a021a8bf8e030fa6bc6ebd3d6","taxonomy_1":"template","taxonomy_2":"second-street","taxonomy_3":null,"taxonomy_4":null,"taxonomy_5":null,"blox_platform":"desktop","blox_page_type":"index","blox_domain":"magicvalley.com","blox_skin":"flex-editorial","blox_application":"editorial","groups":{"content":"1","advertising":"2","utility":"3"},"content_group":"1","content_group_id":"template","blox_sections":"template,second-street","weather_temp":67,"weather_conditions":"Sunny","subscription_max_views":3});

        
        dataLayer.push(
            {'user_id': __tnt.user.screenName},
            {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
            {'user_subscription': __tnt.user.services ? 'Yes' : 'No'},
            {'utm_label': __tnt.urlHash('utm_label')}
        );
        

        if(__tnt.user.services){
            var falcon_sub_name = Cookies.get('leefalcon_membership');
            dataLayer.push({
                'tncms': {
                    'subscription': {
                        'falcon_service': falcon_sub_name ? falcon_sub_name : '',
                        'user_service_ids': __tnt.user.services
                    }
                }
            });

            var lee_clus = Cookies.get('lee-clus');
            if(!lee_clus){
                if(typeof Storage !== 'undefined'){
                    var lee_ulli = new Date().toLocaleString('en-us', {year: 'numeric', month: '2-digit', day: '2-digit'}).replace(/(\d+)\/(\d+)\/(\d+)/, '$3$1$2');
                    window.localStorage.setItem('lee_ulld', lee_ulli);
                    var lee_ulld_iso8601 = new Date().toISOString();
                    window.localStorage.setItem('lee_ulld_iso8601', lee_ulld_iso8601);
                }
                var lee_clus = Cookies.set('lee-clus', 'true', {path:'/'});
            }
        }

        if(typeof Storage !== 'undefined'){
            var lee_glus = window.localStorage.getItem('lee_ulld');
            if(lee_glus){
                // IE hack
                if(lee_glus.match('/')){
                    var lee_glusIE = lee_glus.split('/');
                    lee_glus = lee_glusIE[2]+lee_glusIE[0]+lee_glusIE[1];
                }
                dataLayer.push({'sub_last_login': lee_glus});
            }
            var sub_last_login_iso8601 = window.localStorage.getItem('lee_ulld_iso8601');
            if(sub_last_login_iso8601){
                dataLayer.push({'sub_last_login_iso8601': sub_last_login_iso8601});
            }
        }
    </script>
    <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TDWDC2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <script>
        (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-TDWDC2');
    </script>

    <script>
        __tnt.googleEvent = function(obj) {
            dataLayer.push({
                'event': 'gaTriggerEvent',
                'gaEventCategory': obj.category,
                'gaEventAction': obj.action,
                'gaEventLabel': obj.label,
                'gaEventValue': obj.value
            });
        }
        __tnt.googleSocial = function(obj) {
            dataLayer.push({
                'event': 'socialEvent',
                'socialNetwork': obj.network,
                'socialAction': obj.socialAction,
                'socialTarget': obj.url
            });
        }
        __tnt.googlePageView = function(obj) {
            var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
            dataLayer.push({
                'event': 'VirtualPageview',
                'virtualPageURL': sURL,
                'virtualPageTitle': obj.title
            });
        }
    </script>
    <!-- End Google Tag Manager -->
        
        
        <div id="site-container">
    
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left " tabindex="-1" aria-label="Left Main Menu">
                <div class="in-drawer-logo"><a href="http://magicvalley.com/"><img class="img-responsive" alt="Twin Falls Times-News" src="https://bloximages.chicago2.vip.townnews.com/central.leetemplates.com/content/tncms/live/global/resources/images/logos/ds/400/magicvalley.com.png?_dc=Jul.Tue.2021"></a></div>
                <button aria-label="Close Main Menu" role="button" class="offcanvas-close-btn in-drawer"><svg viewbox="0 0 12 12"  stroke-width="1" stroke-linecap="round"><line x1="11" y1="1" x2="1" y2="11"></line><line x1="1" y1="1" x2="11" y2="11"></line></svg></button>
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1809898" class="tncms-block lee-drawer-search visible-sm visible-xs"><section id="block-1809898" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1809898" class="search-form-container card clearfix text-center well">
    <form id="site-search-1809898" action="http://magicvalley.com/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group_ default normal ">
        <input id="site-search-1809898-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control search-term" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn_">
            <button id="site-search-1809898-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm"><span class="fas tnt-search"></span></span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1809898-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1809898').submit();
        return false;
    });

    $('#site-search-1809898').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1809898 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1809898 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1809898-term').val() ){
            return true;
        }else{
            return false;
        }
    });
    
    $('.dropdown-toggle-1809898').click(function(){
        setTimeout(function(){
            $('#site-search-1809898-term').focus();
        }, 50);
    });</script></div><div id="tncms-block-1809899" class="tncms-block visible-sm visible-xs"><div id="user-controls-1809899" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://magicvalley.com/users/login/?referer_url=https%3A%2F%2Fmagicvalley.com%2Ftemplate%2Fsecond-street%2F" class="btn btn-link btn-sm user-control-link" rel="nofollow">Log In</a></li><li><a href="http://magicvalley.com/members/join/" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                            
                                Become a Member
                            
                        </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://magicvalley.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1809899').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline"><li class="no-service pull-right">
                    <a href="http://magicvalley.com/members/join/" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        
                            Become a Member
                        
                    </a>
                </li><li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" ><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://magicvalley.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://magicvalley.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://magicvalley.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1809899').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
            
        </ul>
    </div>
</div>

<form method="post" action="https://magicvalley.com/users/logout/" id="user-logout-form-1809899"><input type="hidden" name="referer_url" value="https://magicvalley.com/template/second-street/"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><ul id="mobile-nav-left_menu" class="nav navbar-nav nav-level-top" aria-label="navigation"><li>
                <a class="nav-linktnt-section-news" href="http://magicvalley.com/news" >
                    
                        <span class=""></span>
                    <span class="nav-label">News</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-local" href="http://magicvalley.com/news/local" >
                                    <span class="nav-label">Local</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-crime" href="http://magicvalley.com/news/local/crime-and-courts" >
                                    <span class="nav-label">Crime</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-business" href="http://magicvalley.com/business/" >
                                    <span class="nav-label">Business</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-the-big-story" href="http://magicvalley.com/bigstory/" >
                                    <span class="nav-label">The Big Story</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-politics" href="http://magicvalley.com/news/local/govt-and-politics/" >
                                    <span class="nav-label">Politics</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-state-regional" href="http://magicvalley.com/news/state-and-regional" >
                                    <span class="nav-label">State & Regional</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-national" href="http://magicvalley.com/news/national" >
                                    <span class="nav-label">National</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-world" href="http://magicvalley.com/news/world/" >
                                    <span class="nav-label">World</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-multimedia" href="http://magicvalley.com/multimedia/" >
                                    <span class="nav-label">Multimedia</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-covid-19" href="http://magicvalley.com/resources" >
                                    <span class="nav-label">COVID-19</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-news-tip" href="http://magicvalley.com/news-tip/" >
                                    <span class="nav-label">News Tip</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-obituaries" href="http://magicvalley.com/news/local/obituaries/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Obituaries</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-share-a-story" href="http://magicvalley.com/place_an_ad/obituaries" >
                                    <span class="nav-label">Share a story</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-recent-obituaries" href="http://magicvalley.com/news/local/obituaries/" >
                                    <span class="nav-label">Recent Obituaries</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-find-an-obituary" href="http://magicvalley.com/news/local/obituaries/search/?c=news/local/obituaries*&amp;t=article,collection" >
                                    <span class="nav-label">Find an Obituary</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-opinion" href="http://magicvalley.com/opinion" >
                    
                        <span class=""></span>
                    <span class="nav-label">Opinion</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-submit-a-letter" href="http://magicvalley.com/forms/contact/letter_to_the_editor/" >
                                    <span class="nav-label">Submit a letter</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-letters" href="http://magicvalley.com/opinion/letters" >
                                    <span class="nav-label">Letters</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-editorial" href="http://magicvalley.com/opinion/editorial" >
                                    <span class="nav-label">Editorial</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-guestcolumnists" href="http://magicvalley.com/opinion/columnists" >
                                    <span class="nav-label">Guest/Columnists</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-sports" href="http://magicvalley.com/sports" >
                    
                        <span class=""></span>
                    <span class="nav-label">Sports</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-local" href="http://magicvalley.com/sports/local/" >
                                    <span class="nav-label">Local</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-high-school" href="http://magicvalley.com/sports/high-school" >
                                    <span class="nav-label">High School</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-college" href="http://magicvalley.com/sports/college/" >
                                    <span class="nav-label">College</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-csi" href="http://magicvalley.com/sports/college/csi" >
                                    <span class="nav-label">CSI</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-bsu" href="http://magicvalley.com/sports/college/bsu" >
                                    <span class="nav-label">BSU</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-outdoors" href="http://magicvalley.com/outdoors/" >
                                    <span class="nav-label">Outdoors</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-professional" href="http://magicvalley.com/sports/professional/" >
                                    <span class="nav-label">Professional</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-entertainment" href="http://magicvalley.com/entertainment" >
                    
                        <span class=""></span>
                    <span class="nav-label">Entertainment</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-event-calendar" href="http://magicvalley.com/calendar" >
                                    <span class="nav-label">Event Calendar</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-games" href="http://magicvalley.com/games" >
                                    <span class="nav-label">Games</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-movies" href="http://magicvalley.com/entertainment/movies" >
                                    <span class="nav-label">Movies</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-music" href="http://magicvalley.com/entertainment/music" >
                                    <span class="nav-label">Music</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-television" href="http://magicvalley.com/entertainment/television/" >
                                    <span class="nav-label">Television</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-tv-guide" href="http://magicvalley.com/entertainment/television/listings" >
                                    <span class="nav-label">TV Guide</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-contests" href="http://magicvalley.com/contests/" >
                                    <span class="nav-label">Contests</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-lifestyles" href="http://magicvalley.com/lifestyles/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Lifestyles</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-food" href="http://magicvalley.com/lifestyles/food-and-cooking/" >
                                    <span class="nav-label">Food</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-faith" href="http://magicvalley.com/lifestyles/faith-and-values/" >
                                    <span class="nav-label">Faith</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-health" href="http://magicvalley.com/lifestyles/health-med-fit/" >
                                    <span class="nav-label">Health</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-home-garden" href="http://magicvalley.com/lifestyles/home-and-garden/" >
                                    <span class="nav-label">Home & Garden</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-parenting" href="http://magicvalley.com/lifestyles/parenting/" >
                                    <span class="nav-label">Parenting</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-people" href="http://magicvalley.com/people/" >
                                    <span class="nav-label">People</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-pets" href="http://magicvalley.com/lifestyles/pets/" >
                                    <span class="nav-label">Pets</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-travel" href="http://magicvalley.com/travel/" >
                                    <span class="nav-label">Travel</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-voice" href="http://magicvalley.com/community/mini-cassia/" >
                    <span class="nav-label">Voice</span>
                </a></li><li>
                <a class="nav-linktnt-section-feast-and-field" href="http://magicvalley.com/lifestyles/food-and-cooking/feast-and-field/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Feast and Field</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-partners" href="http://magicvalley.com/lifestyles/food-and-cooking/feast-and-field/partners/" >
                                    <span class="nav-label">Partners</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-brand-ave-studios" href="http://magicvalley.com/brandavestudios/" >
                    <span class="nav-label">Brand Ave. Studios</span>
                </a></li></ul></div>
                
                <div id="tncms-region-nav-mobile-nav-left-below" class="tncms-region-nav"><ul id="mobile-nav-left-below_menu" class="nav navbar-nav nav-level-top" aria-label="navigation"><li>
                <a class="nav-linktnt-section-print-edition" href="http://magicvalley.com/eedition" >
                    
                        <span class=""></span>
                    <span class="nav-label">Print Edition</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-e-edition" href="http://magicvalley.com/eedition" >
                                    <span class="nav-label">E-Edition</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-e-edition-archives" href="http://magicvalley.com/news/archives/" >
                                    <span class="nav-label">E-Edition Archives</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-magazines-events" href="http://magicvalley.com/special-section/" >
                                    <span class="nav-label">Magazines & Events</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-our-publications"  >
                    
                        <span class=""></span>
                    <span class="nav-label">Our Publications</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-mini-cassia-news" href="http://magicvalley.com/community/mini-cassia/" >
                                    <span class="nav-label">Mini-Cassia News</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-buy-sell" href="http://magicvalley.com/ads" >
                    
                        <span class=""></span>
                    <span class="nav-label">Buy & Sell</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-place-an-ad" href="http://magicvalley.com/place_an_ad" >
                                    <span class="nav-label">Place an Ad</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-jobs" href="http://magicvalley.com/jobs" >
                                    <span class="nav-label">Jobs</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-homes" href="http://magicvalley.com/homes" >
                                    <span class="nav-label">Homes</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-cars" href="http://magicvalley.com/autos" >
                                    <span class="nav-label">Cars</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-classifieds" href="http://magicvalley.com/ads" >
                                    <span class="nav-label">Classifieds</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-business-directory" href="http://magicvalley.com/places" >
                                    <span class="nav-label">Business Directory</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-i-love-a-deal" href="http://magicvalley.com/deals/" >
                                    <span class="nav-label">I Love A Deal</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-customer-service"  >
                    
                        <span class=""></span>
                    <span class="nav-label">Customer Service</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-manage-subscription" href="http://magicvalley.com/services" >
                                    <span class="nav-label">Manage Subscription</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-activate-digital-subscription" href="http://magicvalley.com/activate/" >
                                    <span class="nav-label">Activate Digital Subscription</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-newsletter-sign-up" href="http://magicvalley.com/newsletters" >
                                    <span class="nav-label">Newsletter sign-up</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-subscribe" href="http://magicvalley.com/subscribenow" >
                                    <span class="nav-label">Subscribe</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-contact-us" href="http://magicvalley.com/contact" >
                                    <span class="nav-label">Contact us</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-help-center" href="http://magicvalley.com/helpcenter/" >
                                    <span class="nav-label">Help Center</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-mobile-apps" href="http://magicvalley.com/apps/" >
                    <span class="nav-label">Mobile Apps</span>
                </a></li><li>
                <a class="nav-linktnt-section-weather-live-radar" href="https://magicvalley.com/weather/?mode=radar&amp;weather_zip=83301"  target="_blank" rel="noopener">
                    <span class="nav-label">Weather: Live Radar</span>
                </a></li></ul></div>
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-1809892" class="tncms-block lee-follow-us branding-links"><div class="follow-links-1809892 default">
    
    <section id="block-1809892" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://magicvalley.com/facebook" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://magicvalley.com/twitter" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://magicvalley.com/youtube" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://magicvalley.com",
  "sameAs" : ["/facebook","/twitter","/youtube"]
}
</script>
<div class="clearfix"></div></div></div>
                <div class="mobile-nav-copyright">
                    <div class="lee-copy">&copy; 2021 Lee Enterprises</div>
                    <div><a href="http://magicvalley.com/terms">Terms of Service</a> <span class="text-muted">|</span> <a href="http://magicvalley.com/privacy">Privacy Policy</a></div>
                </div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    
    
    
    
    
     
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static" role="navigation">
                
                <div class="navbar-header">
                    
                    
                        <button id="lee-main-menu-btn" aria-label="Main Menu" aria-expanded="false" type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas_lee" data-target="left">
                            <!--<svg viewBox="0 0 20 20"><rect x="1" y="4" fill="#333333" width="20" height="2"></rect><rect x="1" y="9" fill="#333333" width="20" height="2"></rect><rect x="1" y="14" fill="#333333" width="20" height="2"></rect></svg>-->
                           <i class="fas tnt-bars tnt-fw"></i>
                       </button>
                       <script>
                            $('[data-toggle=offcanvas_lee]').on(__tnt.client.clickEvent, function(){
                                $('html').toggleClass('drawer-open active-left');
                                $(this).attr('aria-expanded', 'true');
                                setTimeout(function(){ $('.offcanvas-drawer-left').focus(), 200});
                                return false;
                            });
                            $('.offcanvas-close-btn').on(__tnt.client.clickEvent, function(){
                                $('html').removeClass('drawer-open active-left active-right');
                                $('#lee-main-menu-btn').attr('aria-expanded', 'false');
                                return false;
                            });
                        </script>
                    
                    
                        <div class="pull-right visible-sm visible-xs subscribe-btn">
                            
                                <a href="http://magicvalley.com/members/join/" class="no-service btn btn-primary">Join</a>
                            
                            
                            <a id="lee-mobile-user-icon" class="has-service" href="https://magicvalley.com/users/admin/"></a>
                            <script>
                                if(__tnt.user.services){
                                    if(__tnt.user.avatar){
                                        jQuery('#lee-mobile-user-icon').html('<img src="' + __tnt.user.avatar + '" class="user-icon" alt="user-icon">');
                                    } else {
                                        jQuery('#lee-mobile-user-icon').html('<i class="fas tnt-user tnt-fw user-icon"></i>');
                                    }
                                }
                            </script>
                        </div>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1809858" class="tncms-block"><div id="site-logo-1809858" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="http://magicvalley.com/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/ceea2b8a-5284-11ea-b290-13d75e8e4106.png?resize=200%2C25" 
            srcset="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/ceea2b8a-5284-11ea-b290-13d75e8e4106.png?resize=150%2C19 150w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/ceea2b8a-5284-11ea-b290-13d75e8e4106.png?resize=200%2C25 200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/ceea2b8a-5284-11ea-b290-13d75e8e4106.png?resize=225%2C28 225w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/ceea2b8a-5284-11ea-b290-13d75e8e4106.png 300w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="300"
            height="37"
            alt="site-logo"></a>
        </div></div></div></div>
                            
                        </div>
                    

                                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1809302" class="tncms-block"><style> #main-navigation .navbar-toggle { display: none !important; } </style></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" aria-label="navigation"><li>
                <a class="nav-link  tnt-section-news"  href="http://magicvalley.com/news/" ><span class="nav-label">News</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="http://magicvalley.com/news/local/obituaries/" ><span class="nav-label">Obituaries</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="http://magicvalley.com/sports/" ><span class="nav-label">Sports</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="http://magicvalley.com/eedition/" ><span class="nav-label">E-edition</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-covid-19"  href="http://magicvalley.com/resources" ><span class="nav-label">COVID-19</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-buy-sell"  href="http://magicvalley.com/ads/" ><span class="nav-label">Buy & Sell</span>
                    
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                <script>
                    jQuery(document).ready(function($){
                        var sNavContainer = '#site-navbar-container';
                        var sBodyContainer = '.offcanvas-inner';
                        var sNavHeight = $(sNavContainer).height();
                        var iUnfixPoint = 0;
                        
                        if( __tnt.client.platform.ios ){
                            $(sNavContainer).addClass('affix-sticky');
                        } else {
                            $sNavScroll = false;
                            $(window).on('DOMMouseScroll mousewheel', function(e){
                                if( !$sNavScroll ){
                                    $sNavScroll = true;
                                    setTimeout(function(){
                                        var iFixPoint = $(sNavContainer).offset().top;
                                        var iCurrPoint = $(this).scrollTop();
                                        if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                            if( !$(sNavContainer).hasClass('affix') ){ 
                                                iUnfixPoint = iFixPoint;
                                                $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                            }
                                        } else {
                                            if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                $(sBodyContainer).css('margin-top', 0);
                                            }
                                        }
                                        
                                        $sNavScroll = false;
                                    }, 25);
                                }
                            });
                        }
                    });
                </script>
            
        
    
    
    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                

                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1814383" class="tncms-block lee-eedition-latest lee-track-masthead-left"><section id="block-1814383" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1814383 ">
        <div class="block-title-inner">
            <h4>
                
                Today's E-Edition
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-1814383-4f29b327-2c7e-57de-9a13-665d42e441e2" class="tnt-asset-type-edition clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-eedition">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-4f29b327-2c7e-57de-9a13-665d42e441e2 media-preview edition-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="http://magicvalley.com/eedition/times-news/edition_4f29b327-2c7e-57de-9a13-665d42e441e2.html" class="tnt-asset-link" >                
                
                
                
        
                <img
                    src="http://magicvalley.com/template/second-street/data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Times-News"
                    class="img-responsive lazyload  letterbox default"
                    width="620"
                    height="1268"
                    data-src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/eedition/a/a7/aa76e65c-d2f6-571c-94f2-c7477b39b415/60e3ecb62e135.preview-620.jpg?resize=620%2C1268" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://magicvalley.com/eedition/times-news/edition_4f29b327-2c7e-57de-9a13-665d42e441e2.html" class="tnt-asset-link">
        
        
            Times-News</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1809857" class="tncms-block homepage-masthead lee-track-masthead"><div id="site-logo-1809857" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="http://magicvalley.com/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=200%2C25" 
            srcset="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=150%2C19 150w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=200%2C25 200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=225%2C28 225w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=300%2C37 300w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=400%2C50 400w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=540%2C67 540w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png?resize=640%2C80 640w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/c255062e-5284-11ea-b290-6bb831983321.png 750w"
            sizes="(min-width: 1200px) 570px, calc(50vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="700"
            height="87"
            alt="site-logo"></a>
        </div><div class="logo-bottom"><div class="logo-date">
                Tuesday, July 6, 2021
            </div>
        <ul class="list-inline block-links pos-bottom ">
            
                
                    <li><a href="http://magicvalley.com/eedition/" class="">Print Edition</a></li>
                
            
            
        </ul></div></div></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1814365" class="tncms-block lee-track-masthead"><div id="weather-1814365" class="weather-current size-large pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions ">
            <a href="http://magicvalley.com/weather/?weather_zip=83301" class="dropdown-toggle" >
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc large">
                    <span class="temp">67&deg;</span>
                    
                        <span class="cond">Sunny </span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
                </div>
                
                
            </header>
        </div>
    

    <div id="main-body-container">
    <section aria-label="Promotional Items" id="main-top-container" class="container-fullscreen-region container" tabindex="-1">
        <div id="top-promotional-row">
                <div class="row">
                    <div class="col-xs-6 col-md-3 border-col-right"><div id="tncms-region-global-top-a" class="tncms-region "><div id="tncms-block-1809870" class="tncms-block float-preview lee-track-top-promo"><section id="block-1809870" class="block emphasis-h3   " >
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-1809870-84d15fc1-25b4-5d87-9fb5-144a701dfbf2" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-news tnt-sub-section-national">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-84d15fc1-25b4-5d87-9fb5-144a701dfbf2 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="http://magicvalley.com/news/national/tropical-storm-elsa-lashing-florida-keys-gwen-stefani-blake-shelton-wed-nba-finals-start-tonight/article_84d15fc1-25b4-5d87-9fb5-144a701dfbf2.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="http://magicvalley.com/template/second-street/data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Tropical Storm Elsa lashing Florida Keys; Gwen Stefani, Blake Shelton wed; NBA Finals start tonight"
                            class="img-responsive lazyload ap-photo full default"
                            width="1920"
                            height="1080"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=150%2C84 150w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=225%2C127 225w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=640%2C360 640w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=990%2C557 990w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=1035%2C582 1035w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=1333%2C750 1333w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=1476%2C830 1476w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/8/4d/84d15fc1-25b4-5d87-9fb5-144a701dfbf2/60e43ae2bf6a3.preview.jpg?resize=1920%2C1080 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://magicvalley.com/news/national/tropical-storm-elsa-lashing-florida-keys-gwen-stefani-blake-shelton-wed-nba-finals-start-tonight/article_84d15fc1-25b4-5d87-9fb5-144a701dfbf2.html" class="tnt-asset-link">
        
        
            Tropical Storm Elsa lashing Florida Keys; Gwen Stefani, Blake Shelton wed; NBA Finals start tonight</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                    <div class="col-xs-6 col-md-3 border-col-right"><div id="tncms-region-global-top-b" class="tncms-region "><div id="tncms-block-1809869" class="tncms-block float-preview lee-track-top-promo"><section id="block-1809869" class="block emphasis-h3   " >
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-1809869-22fbf38f-91ca-5f06-96ee-1b71c826231c" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-members-only">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-22fbf38f-91ca-5f06-96ee-1b71c826231c media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="http://magicvalley.com/members-only/yum-save-10-on-orders-of-50-of-mouth-watering-desserts-from-baked-by-melissa/article_22fbf38f-91ca-5f06-96ee-1b71c826231c.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="http://magicvalley.com/template/second-street/data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Yum! Save 10% on orders of $50+ of mouth-watering desserts from Baked by Melissa!"
                            class="img-responsive lazyload full default"
                            width="900"
                            height="506"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/0/bb/0bb9cd9a-5e34-52e6-91f4-e33c550fc5c9/60a5f070b1609.image.png?crop=900%2C506%2C0%2C46&resize=900%2C506&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://magicvalley.com/members-only/yum-save-10-on-orders-of-50-of-mouth-watering-desserts-from-baked-by-melissa/article_22fbf38f-91ca-5f06-96ee-1b71c826231c.html" class="tnt-asset-link">
        
        
            Yum! Save 10% on orders of $50+ of mouth-watering desserts from Baked by Melissa!</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                    <div class="col-xs-6 col-md-3 border-col-right"><div id="tncms-region-global-top-c" class="tncms-region "><div id="tncms-block-1809871" class="tncms-block float-preview lee-track-top-promo"><section id="block-1809871" class="block emphasis-h3   " >
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-1809871-ab77e82f-1239-589f-9f76-eff563ed5685" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-members tnt-sub-section-promo tnt-sub-section-email">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-ab77e82f-1239-589f-9f76-eff563ed5685 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="http://magicvalley.com/members/promo/email/get-your-grill-on-with-recipes-from-our-food-drink-newsletter-sign-up/article_ab77e82f-1239-589f-9f76-eff563ed5685.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="http://magicvalley.com/template/second-street/data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Get your grill on with recipes from our Food &amp; Drink newsletter! Sign-up:"
                            class="img-responsive lazyload full default"
                            width="900"
                            height="506"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/a/af/aaf962df-9d13-54ff-b296-81fb7631a31e/60dab3605405e.image.jpg?crop=900%2C506%2C0%2C46&resize=900%2C506&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://magicvalley.com/members/promo/email/get-your-grill-on-with-recipes-from-our-food-drink-newsletter-sign-up/article_ab77e82f-1239-589f-9f76-eff563ed5685.html" class="tnt-asset-link">
        
        
            Get your grill on with recipes from our Food & Drink newsletter! Sign-up:</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                    <div class="col-xs-6 col-md-3"><div id="tncms-region-global-top-d" class="tncms-region "><div id="tncms-block-1809872" class="tncms-block float-preview lee-track-top-promo"><section id="block-1809872" class="block emphasis-h3   " >
    
    <div class="card-img-sm">
        
                
                <article id="card-summary-1809872-54773297-739a-57e1-b5ae-a545dcb27012" class="tnt-asset-type-video clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-lifestyles tnt-sub-section-health-med-fit">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-54773297-739a-57e1-b5ae-a545dcb27012 media-preview video-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="http://magicvalley.com/lifestyles/health-med-fit/lower-your-cholesterol-by-eating-these-foods/video_54773297-739a-57e1-b5ae-a545dcb27012.html" class="tnt-asset-link" >                
                
                
                
        
                        <img
                            src="http://magicvalley.com/template/second-street/data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Lower your cholesterol by eating these foods"
                            class="img-responsive lazyload ap-photo full default"
                            width="1920"
                            height="1080"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=150%2C84 150w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=225%2C127 225w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=640%2C360 640w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=990%2C557 990w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=1035%2C582 1035w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=1333%2C750 1333w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=1476%2C830 1476w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/assets/v3/editorial/5/47/54773297-739a-57e1-b5ae-a545dcb27012/60c37739c9c3b.image.jpg?resize=1920%2C1080 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="http://magicvalley.com/lifestyles/health-med-fit/lower-your-cholesterol-by-eating-these-foods/video_54773297-739a-57e1-b5ae-a545dcb27012.html" class="tnt-asset-link">
        
        
            Lower your cholesterol by eating these foods</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                </div>
            </div></section>
    <section aria-label="Main Content" id="main-page-container" class="container" tabindex="-1">
        <div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1809866" class="tncms-block lee-breaking-live lee-track-breaking-live breaking-news-bar"></div></div></div>
        </div><div id="grid-featured-top-container">
        <section id="grid-featured-top">
            <div class="row">
                <div class="col-md-12"><div id="tncms-region-index-featured-top" class="tncms-region "></div></div>
            </div>
        </section>
    </div>

    

    <section id="grid-full-top">
        <div class="row">
            <div class="col-md-12"><div id="tncms-region-index-full-top" class="tncms-region "></div></div>
        </div>
    </section>

    <section id="grid-primary-container">
        <div class="row">
            <div class="col-md-12"><div id="tncms-region-index-primary" class="tncms-region "><div id="tncms-block-1809750" class="tncms-block"><section id="second-street-container" class="block">
<!-- End Partner Top Branding -->
    <!--[if lte IE 8]>
        <div style="width: 100%; 
            background: red; 
            border: 1px black; 
            padding-top: 10px;
            padding-bottom: 10px;
            color: #fff;
            text-align: center; 
            font-weight: bold;
            font-size: 18px">
            Sorry, you are using an unsupported browser. This page will not display correctly.<br />
            <a href="https://www.unsupportedbrowser.site/" style="color: #fff;" target="_blank">Please click here to upgrade to a newer browser</a>.
        </div>
    <![endif]-->
        <script src="https://embed-813452.secondstreetapp.com/Scripts/dist/embed.js" data-ss-embed="promotion" data-opguid="47d56d2a-b9f1-4e04-859f-8a8e5653c039" data-routing="history" data-root-url="http://magicvalley.secondstreetapp.com/Heres-the-Scoop/" ></script>
        <noscript>
            JavaScript must be enabled to enter this promotion.
            <a href="http://enable-javascript.com/" target="_blank">Click here to learn how to enable JavaScript.</a>
        </noscript>
<!-- Begin Partner BottomBranding -->
</section></div></div></div>
            
        </div>
    </section>

    

    <section id="grid-full-middle">
        <div class="row">
            <div class="col-md-12"><div id="tncms-region-index-full-middle" class="tncms-region "></div></div>
        </div>
    </section>

    <section id="grid-secondary-container">
        <div class="row">
            <div class="col-md-12"><div id="tncms-region-index-secondary" class="tncms-region "></div></div>
            
        </div>
    </section>

    <section id="grid-full-bottom">
        <div class="row">
            <div class="col-md-12"><div id="tncms-region-index-full-bottom" class="tncms-region "></div></div>
        </div>
        
    </section>
    
    <section id="grid-featured-bottom">
        <div class="row">
            <div class="col-md-12"><div id="tncms-region-index-featured-bottom" class="tncms-region "></div></div>
        </div>  
    </section>
    
    <div class="row">
                <div class="col-md-12"><div id="tncms-region-index-container-bottom" class="tncms-region "></div></div>
                <div class="col-md-12"><div id="tncms-region-front-index-container-bottom" class="tncms-region "></div></div>
            </div><div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1809893" class="tncms-block site-logo-container"><div id="site-logo-1809893" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="http://magicvalley.com/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=200%2C25" 
            srcset="https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=150%2C19 150w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=200%2C25 200w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=225%2C28 225w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=300%2C37 300w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=400%2C50 400w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=540%2C67 540w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png?resize=640%2C80 640w, https://bloximages.chicago2.vip.townnews.com/magicvalley.com/content/tncms/custom/image/19004600-5285-11ea-b290-1f9eaff1cf2d.png 750w"
            sizes="(min-width: 1200px) 380px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="700"
            height="87"
            alt="site-logo"></a>
        </div></div></div><div id="tncms-block-1809894" class="tncms-block site-follow-us branding-links"><div class="follow-links-1809894 default">
    
    <section id="block-1809894" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://magicvalley.com/facebook" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://magicvalley.com/twitter" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://magicvalley.com/youtube" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://magicvalley.com",
  "sameAs" : ["/facebook","/twitter","/youtube"]
}
</script>
<div class="clearfix"></div></div></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1809896" class="tncms-block site-footer-heading"><section id="block-1809896" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1809896 ">
        <div class="block-title-inner">
            <h4>
                
                Sites &amp; Partners
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" aria-label="navigation"><li>
                <a class="nav-link  tnt-section-print-edition-online"  href="http://magicvalley.com/eedition" ><span class="nav-label">Print Edition Online</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-magic-valley-wheels"  href="http://magicvalley.com/autos/" ><span class="nav-label">Magic Valley Wheels</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-i-love-a-deal"  href="http://magicvalley.com/deals/" ><span class="nav-label">I Love A Deal</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="http://magicvalley.com/online_features" ><span class="nav-label">Online Features</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-amplified-digital-agency"  href="https://amplifieddigitalagency.com/twin-falls-id/"  target="_blank" rel="noopener"><span class="nav-label">Amplified Digital Agency</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-caped-scholars"  href="http://magicvalley.com/exclusive/scholars/" ><span class="nav-label">CapEd Scholars</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-magazines-events"  href="http://magicvalley.com/special-section/" ><span class="nav-label">Magazines & Events</span>
                    
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1809897" class="tncms-block site-footer-heading"><section id="block-1809897" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1809897 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list" aria-label="navigation"><li>
                <a class="nav-link  tnt-section-customer-service"  href="http://magicvalley.com/customer-service/" ><span class="nav-label">Customer Service</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="http://magicvalley.com/subscribenow/" ><span class="nav-label">Subscribe</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-activate"  href="http://magicvalley.com/activate/" ><span class="nav-label">Activate</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-advertise"  href="http://magicvalley.com/place_an_ad/" ><span class="nav-label">Advertise</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-email-alerts"  href="http://magicvalley.com/newsletters/" ><span class="nav-label">Email Alerts</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="http://magicvalley.com/contact/" ><span class="nav-label">Contact Us</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-about-us"  href="http://magicvalley.com/about/" ><span class="nav-label">About Us</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-work-here"  href="http://lee.net/careers/opportunities/?utm_source=newspaper&amp;utm_medium=blox&amp;utm_campaign=workhere"  target="_blank" rel="noopener"><span class="nav-label">Work here</span>
                    
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1809895" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1809895"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="http://magicvalley.com/">Times-News</a>, 132 Fairfield ST W Twin Falls, ID</small><small>&nbsp;| <a href="http://magicvalley.com/terms">Terms of Use</a></small><small>&nbsp;| <a href="http://magicvalley.com/privacy">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
    </script>
    
        <script type="text/plain" class="optanon-category-C0004">
            
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc6894.add('act', dmpData);_cc6894.bcp();
            });
        });
    
        </script>
    
    
<script>/*<![CDATA[*/ 
        if( __tnt.user.services ){
            jQuery('body').addClass('has-service');
            jQuery('body').removeClass('no-service');
        } else {
            jQuery('body').addClass('no-service');
            jQuery('body').removeClass('has-service');
        }
     /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
        var oAmazonUrls = $("a[href*='amazon.com']");
        if( oAmazonUrls.length > 0 ){
            var sTrkId = 'tracking_id=leeenter0889-20';
            $(oAmazonUrls).each(function(i,e){
                var sHref = this.href;
                if ( !sHref.match(/[?&]tracking_id/) ) {
                    sHref += ((sHref.indexOf('?') > -1) ? '&' : '?') + sTrkId;
                    $(this).attr('href',sHref).attr('target','_blank');
                }
            });
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
        var sTrackingPattern = 'lee-track-';
        var oTrackBlocks = $('div[class*="'+sTrackingPattern+'"]');
        var sTrackVal;
        function lee_trkLinkSrc(o, src){
            var src = 'http://magicvalley.com/template/second-street/tracking-source='+src;
            $(o).find('a').each(function(){
                var sHref = this.href;
                var sOg = $(this).attr('href');
                if (!sHref.match(/[#&]tracking-source/) && sHref != '' && sHref != '#' && sOg.charAt(0) == '/') {
                    sHref += ((sHref.indexOf('#') > -1) ? '&' : '#') + src;
                    $(this).attr('href', sHref);
                }
            });
        }
        if( oTrackBlocks.length > 0 ){
            $(oTrackBlocks).each(function(){
                var sTrackClass = $(this)[0].classList;
                $(sTrackClass).each(function(i,c){
                    if( c.match(sTrackingPattern) ){
                        sTrackVal = c.replace(sTrackingPattern, '');
                        return false;
                    }
                });
                lee_trkLinkSrc(this, sTrackVal);
            });
        }
        lee_trkLinkSrc('#main-nav_menu', 'main-nav');
        lee_trkLinkSrc('#mobile-nav-left_menu,#mobile-nav-left-below_menu', 'menu-nav');
    }); /*]]>*/</script>
<script src="https://tagan.adlightning.com/leeenterprises/op.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
        var lee_sub_level = Cookies.get('leefalcon_membership');

        if(__tnt.user.loggedIn && lee_sub_level){
            __tnt.log(lee_sub_level);
            switch(lee_sub_level.toLowerCase()){
                    case 'dob': 
                        lee_sub_level = 'Digital Basic';
                    break;
                    case 'dop': 
                        lee_sub_level = 'Digital Plus';
                    break;
                    case 'silv': 
                        lee_sub_level = 'Silver';
                    break;
                    case 'gold': 
                        lee_sub_level = 'Gold';
                    break;
                    case 'plat': 
                        lee_sub_level = 'Platinum';
                    break; 
            }
            var s_user_class = lee_sub_level.toLowerCase();
            var s_user_html = '<li class="user-subscriber-menu">'+
                '<div class="user-level">Membership level: <span class="level '+s_user_class+'">'+lee_sub_level+'</span></div>'+
                '<div class="user-link"><a href="https://subscriberservices.lee.net/subscriberservices/Content/AccountStatus.aspx?Domain=magicvalley.com">My Membership</a></div>'+
                '<div class="user-link"><a href="http://magicvalley.com/members/">See Benefits</a></div>'+
                '<div class="user-link"><a href="http://magicvalley.com/members/exclusives/">Members Only</a></div>'+
                '<div class="user-link"><a href="http://magicvalley.com/helpcenter/">Help Center</a></div>'+
                '</li>';
            
            $('.user-controls').addClass('falcon-subscriber').find('.dropdown-menu').prepend(s_user_html);
            $('.user-controls').find('.tn-user-avatar').prepend('<i class="fas tnt-certificate user-icon-cert '+s_user_class+'"></i>');
        }
    }); /*]]>*/</script>
<script type="text/plain" class="optanon-category-C0004">/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc6894.add('act', serviceData);_cc6894.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
         /*]]>*/</script></body>
</html>
